-
Notifications
You must be signed in to change notification settings - Fork 0
/
Chef And Division 3 Jan Long Challenge 2021.cpp
129 lines (92 loc) · 2.51 KB
/
Chef And Division 3 Jan Long Challenge 2021.cpp
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
Task: Chef wants to host some Division-3 contests. Chef has N setters who are busy creating new problems for him. The ith setter has made Ai problems where 1≤i≤N
.
A Division-3 contest should have exactly K
problems. Chef wants to plan for the next D
days using the problems that they have currently. But Chef cannot host more than one Division-3 contest in a day.
Given these constraints, can you help Chef find the maximum number of Division-3 contests that can be hosted in these D
days?
Input:
The first line of input contains a single integer T
denoting the number of test cases. The description of T
test cases follows.
The first line of each test case contains three space-separated integers - N
, K and D
respectively.
The second line of each test case contains N
space-separated integers A1,A2,…,AN
respectively.
Output:
For each test case, print a single line containing one integer ― the maximum number of Division-3 contests Chef can host in these D
days.
Constraints
1≤T≤103
1≤N≤102
1≤K≤109
1≤D≤109
1≤Ai≤107
for each valid i
Subtasks
Subtask #1 (40 points):
N=1
1≤A1≤105
Subtask #2 (60 points): Original constraints
Sample Input:
5
1 5 31
4
1 10 3
23
2 5 7
20 36
2 5 10
19 2
3 3 300
1 1 1
Sample Output:
0
2
7
4
1
Explanation:
Example case 1: Chef only has A1=4
problems and he needs K=5 problems for a Division-3 contest. So Chef won't be able to host any Division-3 contest in these 31 days. Hence the first output is 0
.
Example case 2: Chef has A1=23
problems and he needs K=10 problems for a Division-3 contest. Chef can choose any 10+10=20 problems and host 2 Division-3 contests in these 3 days. Hence the second output is 2
.
Example case 3: Chef has A1=20
problems from setter-1 and A2=36 problems from setter-2, and so has a total of 56 problems. Chef needs K=5 problems for each Division-3 contest. Hence Chef can prepare 11 Division-3 contests. But since we are planning only for the next D=7 days and Chef cannot host more than 1 contest in a day, Chef cannot host more than 7 contests. Hence the third output is 7.
Solution:
#include <bits/stdc++.h>
using namespace std;
int main(){
#ifndef ONLINE_JUDGE
freopen("input.txt", "r", stdin);
freopen("output.txt", "w", stdout);
#endif
int t;
cin>>t;
while(t--){
int n,k,d,a,sum=0,cnt=0;
cin>>n>>k>>d;
for(int i=0;i<n;i++){
cin>>a;
sum+=a;
}
if(sum<k){
cout<<0;
}
else{
cnt = sum/k;
if(cnt>d){
cout<<d;
}
else{
cout<<cnt;
}
}
cout<<endl;
}
return 0;
}